0 votes

Hello,

For a client on premise (Amma) we need to upgrade their existing efficy 10SP2 to Efficy11.2.

We have a dev server where we have been testing 11.2 without any problems. But when we wanted to upgrade the production server we encountered an issue.

I was able to install efficy correctly. We were even able to reach the login page but after login this message appeared as a alert message : "class not registered, classid: {16d51579-a30b-4c8b-a276-0ff4dc41e755}"

Efficy then succesfully logins but isn't able to retreive any data (same error message inside the crm).

It seems that efficy tries to get a class id in the registry that isn't registered on the production server (seems to be jscript). It is registered on the dev server.

Is this something that the efficy installer registers or is this more linked to the local server settings?

Thank you for any information.

Ken

asked in Efficy Installation/Settings by (190 points)
Do other utilities that use the jscript script engine also generate these exceptions on that server? For instance a DataSynchro or Scheduled script?

Maybe restart the server?

1 Answer

0 votes
Best answer

This is the ClassID for the Javascript engine jscript9.dll that comes with Internet Explorer.
Make sure to have IE installed on the production server, otherwise none of the ServerJS or workflow scripting will work.

answered by (1.2k points)
selected by
Thank you for the information! It does seem to be something of this sort, IE on this server hasn't been updated since 2009 wich could be the reason for the failing js scripting (wich isn't the case on the dev server).
1,231 questions
1,500 answers
1,835 comments
328 users